My PSVita can't turn on

Discussion in 'PS Vita Help' started by Wang Zilin, Jan 4, 2012.

  1. Wang Zilin

    Wang Zilin New Member

    10
    0
    1
    My friend bought me a PSvita at HK, it perform so nice. but this morning I can't turn it on after one night fully charge! what can I do? the 'PS buttom' is keep lighting in blue. Is there any reset buttom on it? Or I have to send it back to HK?
     
  2. cd0g43

    cd0g43 Active Member

    271
    63
    28
    There has been many people with this exact problem. What has usually resolved the issue for them is by basically letting it blink until all of the power is gone, and then charging it. This person has made a video about the same problem that he had with his vita which he fixed by doing that, That was what he said he did to fix it in the comments section of the video:

    Best of luck to you, and I hope this helps.
     
  3. Wang Zilin

    Wang Zilin New Member

    10
    0
    1
    Nope it's not blinking. It just keep blue.
     
  4. cd0g43

    cd0g43 Active Member

    271
    63
    28
    Well it might be worth a try using the same process, but if that doesn't fix it I'm out of ideas :/ maybe do some google searches and see what other people have done for this problem.
     
  5. Wang Zilin

    Wang Zilin New Member

    10
    0
    1
    What the hell....
    So normally how long should I waiting for all power gone?
    one month..? T.T
     
  6. cd0g43

    cd0g43 Active Member

    271
    63
    28
    Thats what I'm wondering :/ haha. Have you tried customer support?
     
  7. Wang Zilin

    Wang Zilin New Member

    10
    0
    1
    I don't think it works, coz it's HK version and I am in SIngapore now. My friend bought it for me as the Chrismas present and I don't think he will keep the reciept.
     
  8. AKool28

    AKool28 IVIaster IVIod

    5,425
    2,096
    273
    Country:
    United States
    PSN:
    IVIasterJason
    try plugging it in for about 4 hours, then try to power it up... hope this works,
    AKool
     
  9. Wang Zilin

    Wang Zilin New Member

    10
    0
    1
    Ok trying..the light is turning into pink
     
  10. AKool28

    AKool28 IVIaster IVIod

    5,425
    2,096
    273
    Country:
    United States
    PSN:
    IVIasterJason
    just tell us if that works! good luck!
     
  11. kaizere

    kaizere Well-Known Member

    1,791
    247
    113
    I think when you fix that problem you need to update your vita just like the others did...
     
  12. Wang Zilin

    Wang Zilin New Member

    10
    0
    1
    nope it doesn't works. WTF!!!
     
  13. Wang Zilin

    Wang Zilin New Member

    10
    0
    1
    SHIT!! I hold the power buttom for at least 1 min...
    It finally turned off....
    Anyway.. thx for all the help!!
     
  14. AKool28

    AKool28 IVIaster IVIod

    5,425
    2,096
    273
    Country:
    United States
    PSN:
    IVIasterJason
    Glad to hear its fixed...You should probably do what kaizere said, and update it
     
  15. slimingcheese

    slimingcheese Active Member

    511
    50
    28
    Country:
    Japan
    PSN:
    XerveX
    Try this Press and hold the Power button while the charger is connected for 30seconds after 30seconds unplug the charger and release. if it won't turned on press the power once for 5 seconds... hope this will hep
    (if necessary take the SD out)


     
  16. ロリ狩りクン

    ロリ狩りクン Member

    45
    12
    8
    PSN:
    Katamaridamashi
    so this happend to my vita a few times this works
    hold the power button for 20 seconds
    then let go
    then hold the power button for 3 seconds
    then let go
     
  17. ShinFuYux

    ShinFuYux Active Member

    332
    131
    43
    Country:
    United States
    PSN:
    kuroi_kawa
    I think it's an OS problem, that could be the reason why it's all screwy.

    I can imagine sony will release a new firmware update by the international launch.
     

Share This Page